Poor running

My car seems to be getting less and less happy with running at part throttle. It jumps about all over the place when running at very slight throttle, especially under 2000 rpm.

I’ve balanced the throttles as good as i can. They are now all running within 0.5 Kg/hr of each other. Does anyone have any suggestions as to what else i can try.

Also whats involved with changing to an Emerald ECU? Is a new loom and instrumentation required?

Cheers

Could very easily be a dodgy Throttle Position Sensor, does it jump about loads when at steady part throttle? If so then probably that… You can reset the TPS with the ignition on and appling full throttle 5 times (this doesn’t reset the ECU like some seem to think)… This is with the engine off

Otherwise get to any ol’ rodder scappy and get one off any K series’d car, then fit and do the 5 full throttle’s again. They’re about �50 new which is a bit steep IMHO.

The emerald isn’t too tricky to fit, even I managed it so it can’t be rocket science You need to chop the wires off the old ecu plug (but do this as you attach them to the new Emerald plug!!!) and just rewire according to the instructions, the guys at Emerald are really really helpful and know their stuff…

Oh and if you do it yourself, order a new spine for once you’ve done

Have you cleaned your IACV recently?

Yeah its like a feckin kangaroo with piles. Seems to be getting worse too. I’ve tried the resetting trick you suggested but no luck (thought that only calibrated the IACV ). How easy is the TPS to fit then?

How much am i looking at for an Emerald and all the kit needed to go along with it and does it come with any maps (190 spec)?

Uldis,

Yeah i cleaned out the IACV whilst i was balancing the butterflies. It was fairly full of muck. Didnt make it run any better though.

Udlis, the IACV will only effect idle… He’s getting toruble on part throttle. The 5 times to full throttle is only for calibrating the TPS to the ECU (on the rover MEMS, maybe does nothing on the Exige ECU ).

Wouldn’t be the IACV, almost 123.45982% certain it’s the TPS, I know as mine’s just gone As the TPS signal is jumping all over the place you’re getting random fueling for a static throttle opening so it starts to kangeroo and play silly buggers… But give it some berries and it’s a little better (but still not quite sweet).

Very easy to change, 2 x 3mm hex bolts on the left hand side (passenger side, UK) of the throttle bodies, half way up, black thingy with plug into the bottom (all inline with the throttle linkage)

[image]http://forums.seloc.org/viewthread.php?action=attachment&tid=27241&pid=397840[/image] (needs a SELOC acc. & ignore the rain jacket, that’s what my TPS needs LOL!)

Comes off of any K series engine. Trust me, that’s what it is

No worries RemarkLima

I’ll get myself down to the local scrappies and see if i can find a rover TPS. Hopefully it’ll do the trick. Let you know how i get on…

Cheers

Scott

Wouldn’t be the IACV, almost 123.45982% certain it’s the TPS

I know nobody is going to agree with me, but I don’t care no more…
When I took my toy to the expensive Lotus garage, after I had changed the battery for some calcium thingy, they reset my (and the cars!) chip. They said that pressing the accelerator pedal 6 times slowly whilst chanting lines from Monty Pythons Holy Grail and throwing dead toads legs in the air at the same time …doesnt work cos we aint got some oogimyflip valve that they used to put in the elise.

They told me that you have to leave the car ticking over with the a/c on until the electric over heat fan comes on. Then switch the engine off, let it cool down then do it all again - that way the engine chippy thing learns how it runs…
They did’nt explain what you do with the toads legs though or what to do if you aint got no a/c.
Don’t moan at me…I’m only passing on what I was told. If they told me to put the chip in a deep fat frier I’d probably do it!

Antonio

Can’t follow that - brilliant

Wouldn’t be the IACV, almost 123.45982% certain it’s the TPS

Scary isn’t it I have to spend a while asking very dumb questions hen I get into a bit of beardage and there’s no stopping me!!!

scooteroo

has this only recently started because they don’t really like crawling along on part throttle under 2000rpm… any of them… unless modded (eg Jenveys and or Emerald) remember the idle revs are 1250rpm so you are hardly giving it any message at all at 2000rpm…

have you changed fuel types recently?

what’s it like cruising at say 3000rpm? in any gear?

RoxTeddy,

Its definately getting notably worse. Can be driving along at say a constant 30mph in 3rd and it jumps all over the place. I was convinced that the throttles were running out of balance - but i seem to have fixed that and there hasnt been much improvement. It’s worse below approx 2000rpm on the very first few throttle positions, however, it is doing it above that engine speed too.

No luck with sourcing a TPS from the scrappy im afraid. There were plenty of old rover K’s there but they all have different TPS to the one on our engines. There were two types - one for the 8 valve engines and one for the 16 valve engines. Basically they are both bigger and operated via a lever mechanism. On the VHPD engine the throttle spindle inserts into the sensor.

Anyone got a spare one lying around that they could sell me? �50 is indeed very steep for what it is!!

Have you tried a Rover dealer?

Although i understand the prices will be the same but they may be able to tell you what cars use it for your scrap yard hunt.

Scott,

It’s IS off of any 16v K series engine!!! I just got one off of a VVC lump in a scrappies yesterday for �10

In fact any engine from 95 onwards should use the same TPS, it’s the same one as one the Elise as well (even tho it doesn’t have TB’s IYSWIM).

Go forth and try again Take your old TPS with you to compare. They tried to sell me the entire plastic plenum so maybe it’s that

GL!
Mark
P.S. Sounds exactly like the TPS has gone!

Ah i guess that could be the prob. The cars in my local scrappy are 214, 218, and metro’s - they were all older cars pre 1995 i think. They must have changed the design after then.

Oh well off to another scrappy i go

They tried to sell me the entire plastic plenum so maybe it’s that

That’s what I ended up buying but at the time I was just glad that’s all it was AND IT MY PRIDE AND JOY WAS UP AND RUNNING AGAIN - BRMMMMMM!

Ian

ps. If anybody needs a plastic plenum…
pps. With no TPS on it…
ppps. Or an old fault one…

LOL!

Well if anyone was a choice of 3 broken TPS’s just shout

Well eventually tracked down the proper sensor (�3) from the scrappy. Fitted it yesterday and no improvement - doh!!!

Revs seem to be sticking now when i press the clutch and it doesnt want to idle at the right speed (1500 up to 3000 rpm). Got it booked into the garage on Thursday to get a proper tune up and see if they can get to the bottom of the problem.

By the way does anyone know the spec of the bolts used to hold the trumpets to the throttle bodies. Need to replace some of them as the hex heads have rounded off.

Also how is the throttle spring on the left hand pair of bodies supposed to sit? (i.e. one end locks into the pulley - where does the other end sit?)

Cheers,

Scott

Have you been able to reset the TPS? Not too sure how on a Exige ECU…