Meta 99 Immobilser problem ??- HELP PLEASE !

I have a problem with my car that is driving me nuts and need some help please ?
I have searched the archive and have found some related threads but none that match my problem exactly.
First of all I should say that it is an elise I have not an exige (I wish !!) - but it is a 2001 model and has the same alarm as the 340R and the Exige ie the Meta 99.

Some of the time the car is fine - disarms - starts - lovely !
The next time (always at the most embarrassing of moments - it will not run - I disarm as normal, turn the key and it will fire for about 1 to 2 seconds and then die !!
It does not matter what I try it just does the same thing - runs very briefly then is dead.
I can leave it for 30 minutes sometimes and it will be OK - the longest was 3 hours !!
Local alarm dealer says that the alarm is OK and that it is something else - (not too sure how he comes to this conclusion).

Any help would be very gratefully received please ?

Many thanks.

Would do you mean by ‘fire’? Just turn-over, cough a bit but not run, or actaully start running?

After the two seconds what happens when you turn the key? Lights dim, clicking, whiring, silence?


Wow - quick response - thanks !

By fires I mean - turns over and appears to start just as it would normally but only for very short time - a second maybe 2. Then it dies !

If I turn the key again then it will repeat EXACTLY the same start quick stop routine.
Everything else appears normal.
Fully charged car battery too.


Talking this through with somebody else I should perhaps clarify - when the problem exists -I disarm - turn the key and the engine appears to be getting an ignition spark and fuel as normal … but only for about 1 to 2 seconds then it is cut.
Turn the key again and it repeats the fire and die routine.

It only ever does it when it has been running - ie when I first go to the car it has always been OK (tempting fate I know !) - the problem only appears to occur when I have driven some way then stop and try to restart.(!!).

I have no idea how to check the immobiliser myself and can ot understand what else it might be to give the intermitent problem.

Another night in the garage tonight I think !!

Throttle position Sensor! (aka TPS) A search on this site should produce some help.

Good luck

Does the fuel pump prime each time? (whirring noise) on turning the key. I’d start by checking to see if there is power on the injectors when it dies. The immobiliser cuts the power to the fuel pump & coil I think.

Thanks for the suggestions.

Fuel pump is priming (whirring noise) - the rest I still have to check.
Am studying a wiring diagram at present

Thanks again for the tips - any more please ?

If it only happens after the engine has got hot could it be a fuel evaporation problem. If it’s firing it can’t be the immobiliser. In fact it wouldn’t even turn over.

Is the engine running


P.S. I’m no mechanic

Hi tim - thanks for the input. I have just come in for a coffee !
I agree - it is NOT the alarm - I have power to fuel pump and starter motor plus to double check I bridged the immobilser circuit on both and it made no difference !

So I am now off to search on TPS and anything else I can think of !!

Anybody else got any ideas please ?

Throttle position Sensor! (aka TPS) A search on this site should produce some help.

I had this. When hot the TPS read 100% which is on fire=up is ‘spark plug cleaning mode’ and stops the injectors firing. It therefore would turn over and never fire.

Yours doesn’t sound quite the same but that’s definately a possible.

Have a search for ways to short circuit the immob. That would rule that out.

Good luck!


Ian - you are a star - thank you !

Bypassed the immobiliser and still the same symptons - so then next cilprit was the TPS - thankfully I hada spare throttle body and TPS so changed the TPS as suggested and HEY PRESTO - my car lives again !! Definately need a good drive now to rekindle the love and erase the bad thoughts of earlier !!

Thanks to all for your help - I wish I had come on here earlier !
Definately a good reason to keep saving for an Exige too - one day !

I humblely doth my cap at Pesky too. He got to the solution first.

V.glad it’s fixed!


Quite right ! My apologies Pesky - I did not look back carefully enough as to who had suggested the tps first - my thanks !
It was very pleasant feeling this morning to be able to start my car whenever I wanted too !

Spoke too soon !!

Car has now reverted to it’s exact fault as before !!

Changing the tps last night seemed to have solved the problem - tried it about 8 times - started no problem. Started Ok this morning and after a short run / stop but then an hour later the exact same problem as before - any suggestions (other than a piece of rag in teh petrol tank and a match!) very gratefully received please ?

Is it possable that there is another fault that is frying the tps ?

Idle control?


Thanks for the suggestion and apologies for being very limited in knowledge - where / how / what is the idle control please and where is it located please ?


A search on the word ‘idle’ should provide you with much of what you require.

Or it’s blown the TPS again, they seem consumable on some cars, but then you get one it “likes” and you’re fine, seems to take about 3 - 4 goes for some reason

You can get them from scrappies for about �10.

Thanks - I will try cleaning the Idle Control Valve tonight. The brown temp sender has also been suggested (black on S2 ?).

I do have a temp sender so will try that anyway.

Will have to go TPS hunting as I used the only one I had - and it was brand new !!

Thanks again to everyone for the help - fingers crossed !

Thanks to all for the suggestions etc.
Battery is fully charged.
Plugs and dizzy all OK
Have changed TPS (again), changed ECU temp sensor, checked Idle valve, reset ECU, changed multifunction relay - still no difference !!!

It will start Ok when it has been left standing for a while but after a drive it will fire 3 or 4 times but not run !!

I am on the Norfolk / Cambs border - where can I get the fault codes scanned locally please ?