No fuel pump

OK, this thread has been running for a bit on SELOC and I check a couple of the bit’s over here but basically my fuel pump is fooked

I’ve checked the relay (swapping with the main beam relay up front) and all seems OK… So must be something in the wiring above the fuel pump. Now is there a way to get access to this without removing the PX seat and all the inside trim!?!

Hopefully it’s something up there and not the fuel pump (which could be costly I guess)…

Any suggestion appreciated


There is an access panel on the passenger side behind the seat, i.e. underneath the netting, but you would need to get the seat out. This is a relatively simple job if you have some allen keys, or a socket set with allen key bits.

Remember to mark the holes the bolts come out of, cos there are two sets of holes underneath…

Have you checked the fuses/relays which are located in the the “ECU compartment” between the seats? I once found that the 7.5 amp fuse had blown, preventing the car froim starting.

That would make sense, because this all happened when he jump-started the car with another (or so I gather).
Either that or the inertia switch…

But… wasn’t the AA on their way? what did they say?

The Fueses near the ECU are the one’s I checked, and the bottom relay (which I’m sure I can hear click)… None blown up front either.

The AA man has been and gone to no avail, we tried the inertia switch but it wasn’t tripped, so we gave it a knock and the the button popped up so tried again but no joy… We also checked all the wiring to the fuel pump and all was OK but didn’t get to the bit above the fuel pump (didn’t remove the seat…

If it take it out is there anything I could do under there or will it be just wiring and stuff that make no sense?

The AA have offered free recover to a dealer / garage so just otta find one that’s got some free time I reckon

i had the same problem twice with my exige.
The starter runs but no fire. Feul pump does not work when key tuerned to ignition but u have sparks.
It was the throttle sensor…
Easy to check, maybe u have the same problem.
They do not like water, in fact i washed my car carefully
that time then unable to start again. The second time happened after driving in the rain.


Sounds promising!!! Where’s the sensor?

I would suppose nearby the throttle…
Really, I haven’t looked for it in the Exige, but on my GSXR it is at the end of the Butterfly shaft.
Look for it around there.

Looking from the rear is just on the left of TBs.

Udlis, LOL

Nicolas, can you give me a bit more details as to what you did? Is it just a wiggle and see, or replace, or take apart and clean out?

I’m heading home tonight to have another poke around and if it’s that then I’ll be like Rosanne Barr’s knickers! Well chuffed

This is interesting. As I’ve got the motorsport engine cover, I guess mine is quite likely to get wet. Maybe I need to make some sort of cover for it.

What i did was just to replace it with one taken from a friend’s car. I then tested the sensor and noticed that
it was interrupted. This sensor is only a variable resistance, u can test it with a ohmeter.

After it happened the second time i made a small plastic cover to protect it. since then no probs.

So what u can do this evening is just check if the symptoms u have r the same as what i had.

  • No feul pump when ignition on
  • sparks ok
  • starter engine runs
  • no detonation
    If the same u can unbolt the sensor (3 minutes) and check it. Maybe u can ask a friend his sensor just to try.
    Remember that changing the sensor u normally need a ECU reset because there r small differences between sensors.
    Using another one u can have idle problems if not resetting the ecu but the engine will start.


forgot one symptom:

  • injectors were ok, also signal from ecu to injectors was ok, but of course no feul injection because of no feul pressure.

Well the symptoms seem exactly the same… So I really hope this is the case! How much is a new sensor?

So anyone near Rochford, Essex fancy lending me their sensor? Is it common with the Elise?

It is not common…as far as i know.
Anyway i payed in the region of 80�, but here in Switzerland.

OK, just had a poke about the TPS, would it start if it was disconnected?

I haven’t got a multimetre at the mo so can’t check if it’s bust but still touching wood (ooo er!)

OK, just had a poke about the TPS, would it start if it was disconnected?

I haven’t got a multimetre at the mo so can’t check if it’s bust but still touching wood (ooo er!)


It won’t work if you disconnect it, as this would be the same as having it open cct failed.

You would need to provide a signal voltage back to the ECU which was equivalent to the throttle being at idle postition. I don’t know what this volts range will be tho (it might be between 0v & 12v - but don’t bet on that as the ECU may send the volts to the + side of the TPS in the first place, and this might be much less than 12v - so if you put 12v on there youd knacker something).

I just looked at my TPS and it has 3 wires, one will be earth or a 0v ref from ECU, one will be the +ve signal either 12v or something else and maybe from the ECU, the last one will be the potentiometer wiper and this would be the one you would need to send voltage=throttle position back down. My problem is I don’t know which is which and I also don’t have a multimeter so cant test for you. I will get one over the weekend and have a prod around… unless anyone else can tell us before that.

Anyone in Essex and fancy popping over at the weekend to try this TPS thing?


Try a different relay, Trudys car would do that, the relay would click but no fuel pump, tried all the others that were on the block, all clicked but still no fuel pump, SGT replaced the relay and she’s not had any problems since !!

Is the fuel pump relay a different part number from the rest ?

The only relay that I found that was the same was the main beam relay up front, same part no and circuit diag on the block… Made no difference sob sob

I could try a new relay as well… Someone with a S1 Elise near me is heading over for me to try the TPS tho’… I really hope that it works!!!