Issue with DAB radio in S2

hi all…

pick up my exige yesterday and loving it!!

shame about the pants weather!


the radio like scans every 30 seconds and produces a loud beep in my ear!

its very very annoying…

how do i make it stop???



Try removing the unit and leave it out, less weight and no more having to bore yourself with music when trying to listen to your engines sound track!

Failing that, there should be a setting that adjusts the sensitivity of the auto tuning & RDS functions, it’s usually a button with ‘loc’ on it and you can adjust the sensitivity so that it doesn’t try and retune to the strongest signal every 100 yards. I don’t know the head units in the S2 but the stereo’s hand book should tell you where the setting is and how to adjust. Still think my first idea is best though

haha…i did think of the first one…

but its for the times im stuck in traffic…

alos i didnt get a stereo manual…

so if anyone with one could help me out?

I saw a thread about this a while ago on try searching there.

I never use the radio, the DAB reception is pants at best. I installed an Ipod link in mine so I can listen to my own choice of music.

yeh i was listeniong to CDS and it was still doing it…i think i sorted it now…found an online manual and turned the beep off…i hope!

Try removing the unit and leave it out

Sorry you are wrong, you just need to leave out the manual which must run to 987 pages in 29 different languages. But I do agree that DAB reception is rubbish, (so is AM, just try hitting the brakes).
I am not sure you will have solved the problem just by turning off the beep, isnt it still do the searching ?

not sure…

im not too worried about radio…it was just doing it over the Cd’s aswell…tht was annoying…

ill try read more later to see what it is…if anyone else has had the problem please help me in turning it off…

Download the instructions here

I was going to say - then throw the head unit in the bin but it just needs a decent aerial. One of my friends fitted a DAB/FM amlpified aerial and now it works much better.


thanks bob

Seem to recall mine did this at first then I switched off the traffic news and it stopped beeping. generally can’t hear much over the stage 2 but get the occasional waft of sound

yeh i have a stage 2 on mine!!!

In that case use an ipod and a pair of Sennheiser DJ headphones!

mine did the same - i cant remember how i fixed it - its a setting somewhere. i’ll have a think!!