Introduction aaaand...limp mode

Hello everyone, I just recently got an Exige S1…well, recently, it was last summer but just in the past couple of weeks we (we as in the mechanic) have been starting to work on it. I live oversea and spend my summer vacations in Italy: what better car than an Exige S1 with no aircon to drive around Milan’s traffic in 38C temperatures? :thumbup:

Since the maintenance was known but old, i proceeded to change radiator, brakes and pads, all fluids, plugs etc.

Today we took it for a drive and after a couple of 8000rpms shifts the engine dies down and now revs only to 5500rpms.

I am looking for this forum’s help and to tap into your knowledge to see if you can help (aside from saying “get an Emerald” :smiley: )

  • Speed sensor was replaced - no effect
    crankshaft sensor was replaced - no effect
    wires, relais and fuses behind the seats have been checked - nothing wrong

Next step will see if the wiring from the speed sensor to the ECU is faulty (does anyone have a wiring diagram?)

the diagnosis tool says “speed sensor error” but after trying with 3 different ones we all had the same result: 8000rpms for a couple of gears and then boooooooo limp mode.

Do you think the ECU is faulty and if I try with another 170hp one I may solve it?


5500 rpm rev limit was usually an ECU engine protection mode.
Most often cased by, in no particular order
Poor connection at coil pack - make sure plug leads are correct to coil connection - GM made 2 sorts, internal and external pole, and the two don’t interchange, both coils and plug leads.
Vehicle speed sensor - are you getting a good reading at the ECU, not the dash, as there are 2 and independent of each other.
Crank sensor - have seen a couple of these now, where some aftermarket flywheels only have 1 set of trigger teeth to one side of the sensor. Seems to be no problem on Elise’s, but Exige/340R with the EFi ECU, some don’t like it. We have got around it by machining the mounting leg on the crank sensor slightly, so that it goes further into the hole in the block. Don’t go too far though, as you will knock the tip of the sensor off or bend it on the flywheel!!
What is the fault code? Engine speed or vehicle speed fault?

The coils are a bit old but they look good. Upgrading them is next as that would not hurt.

When you say “ Vehicle speed sensor - are you getting a good reading at the ECU, not the dash, as there are 2 and independent of each other.“

Does it mean that there are 2 sensors? Or that the signal splits to ECU and Dash? Speed at the dash is fine.

2 sensors for speed. Left rear for the dash and right rear for the ECU.

We only tested the right rear to the ecu as the dash was fine

The error code that we get is P0501 “ Speed Sensor vehicle A”

Hi & welcome :slight_smile: I can’t really help beyond what’s already posted, but I had a very similar issue with mine, 5500rpm limit and various fault codes. Swapped sensors, checked wiring, nothing. I’m 99% convinced it was an ECU fault as I swapped in a borrowed unit from another car and that worked fine. I’m now running an Emerald!

There are wiring diagrams in the Exige supplement of the service manual (just Google for A111T0327J or PM me and I can send you a PDF) and there’s some details on the bulkhead ECU connector pinout over here - - Lotus exige club if you want to do some continuity testing.

Seen a couple of similar threads recently, I do wonder if these old EFI ECUs are starting to show their age, maybe 20+ year-old electronics inches from a toasty exhaust manifold, it’s to be expected!?

The theory that the ECU may be starting to get old might make sense.

BTW this is totally expected- I guess it’s part of the journey .

I occasionally get a stutter at 5500rpm and the car won’t rev past this point.

Every time I know what it is.

An air pocket can develop where the HT leads connect to the coil pack. The instructions with the HT leads even describes seating them carefully by lifting the rubber boot at one side as they are located into position to ensure no air pocket is trapped when they are fitted.

I disconnect each HT lead and reseat. Strange phenomenon but it happens. Why I don’t know. Does this happen on any other car?!

Good luck :wink:

Thanks for the tip.
At this point I have the following options:

1- Leave with the mechanic as he takes it to an “ECU guy” to look into this and pray.
2- Drive as is (limp mode) while in Italy, then drop it off to get a megasquirt installed
3- Order an Emerald (which will take about 10 days all said and done) At this point I would get the pulleys too, maybe get the car ready by mid july (maaaaaaybe)
4- Order a megasquirt - no idea on timing.

No 1

hmm I’d go option 1 and then option 3 if no joy on the original ECU (simply because I know nothing about Megasquirts :smiley: )

An advantage of the Emerald is if you order a new one from them they can pre-configure the ECU with the correct config and map, and supply a plug+play loom adapter. You’ll probably want to tweak the map and timing on a rolling road to get it spot on, but you could be up and running again fairly quickly :thumbup:

That’s a good point, although my mechanic thinks that the Emerald is “too old” and there are finer ECUs nowadays.
I think that the Exige is quite old so probably the Emerald is fine, but I am no ECU expert. BTW the folks at Emerald have been great in email correspondence.

Well, a weekend in Italy without a Lotus and in a Punto 1.4 with auto box: this has to be purgatory

We found the issue! A split wire was making contact on acceleration, triggering the fault.

I say “we” but I actually just answered the phone and they told me that.

Still hunting for an Emerald though

Congats! Enjoy your driving

Great news, and good job by whoever found the problem :clap: . Wiring faults are hard enough to track down, let alone one that only happens under acceleration :crazy:

Thanks peeps! I got a text at 1am with an emoji of a bottle of champagne popping :slight_smile:

I am off to Goodwood tomorrow but should go pick up the Exige next Tuesday.

Full tank of VPower and some right foot oil

Readying all the thread, can you please describe with exact wire was split ?

I have the exact same problem, testing 3 ecu… all sensors … wiring I am getting crazy.

Really looking forward reading you answer