Calling ECU experts (How about you Mr Pesky!)

Been out to Donnington today and have had major problems with I think the ECU? Car has intermittent fault at 5500rpm bit like the old 190 stutter which Lotus recalled. This time its worse the engine�s loosing power big time and overall powers down. Tried flicking the engine cut off which works fore a bit then it just comes back.

Most of you know me (Anthony Reeley with the �Mclaren West� paint job)just had problems in logging on? Anybody know what�s going on with my pride and joy�.help!


Sorry to hear this.

I presume that your car has had the ECU recall? If so, switching off the engine for 20 to 30 seconds is the first thing to try. However, I imagine that you’ve already done that! Next, try looking at the electrical connector for the wheel speed sensor - located on the driver’s side rear hub. This can get full of crap/corrosion, & a good clean might solve the problem. If it “thinks” there is a misfire, it limits the ECU to 5500rpm. If that fails, the speed sensor itself (it screws into hub) could be duff, & should be replaced - costs about �80 I recall.

Best solution is of course to ditch the Lotus ECU & fit an Emerald one!
Good luck.

I had something similar that I believed was happening because one cylinder wasn’t firing properly, all the power slowly drained away until I came to a halt. The new ECU prog trys to stop anything major from happening to the engine by limiting revs to 5000(ish) when it detects trouble (not always correctly I guess).

Have you checked leads, plugs and injectors?


Just a thought and i am propably way off the mark here but what about the lamda sensor, mine goes because i use leaded racing fuel but it was causing the car to run terribly.

Apologise if my mechanical knowledge is as useful as sewing skills.

Apologise if my mechanical knowledge is as useful as sewing skills.

That makes two of us then!

Well as it’s down on power it’d suggest a misfire… So the usual plugs, leads, coil… Or as jason says if the lamda’s foobar’d then it could be running rich which will clog up the plugs causing a misfire… Can you feel a misfire?

Next is the wheel speed sensor as said.

But your best bet is to get thee to a Lotus dealer and get the ECU read for error codes, it’ll tell you if a sensor is f**ked.

If there’s no power loss until the 5.5k limit the ECU cut’s the cylinder that it misfires on so that could explain the power loss.


What about checking the plugs to see if one is sooted up.

An AA chap will tell you the ECU error codes. Although the last one to look at my car told me had never had a K-series report an error code.


Thanks lads, I think at this point I do need to get it to a dealer first to try and see where the fault is. I�ve pretty much tried most of the things, thing that bothers me is that it is intermittent. Ill keep you posted but if there is anything else let me know�thanks.

The ECU will remember codes so you should have a log of all that’s gone wrong

I didn’t think AA man could read Exige ECU’s as they were different to the standard rover MEMS thingybob… But could be wrong

Well his funky tough wireless laptop (linked to an Internet link in the van) had a Lotus Exige/Elise ECU option.


I had this with my car and never did find the problem I tried everything, wheel speed sensor, plugs, leads, coil etc etc.

It’s not too funny when you are half way through overtaking a lorry and you loose all your power .

This may sound daft …

I have a similar problem on my Audi - its a known problem with the MAP sensor on those - Complete pain in the arse - you get to 190 KPH ( in Germany ) and foot to the floor suddenly nothing - power loss … so you pull over ( yeah easy ) and turn ignition off - wait a second or two then back on everything is OK …
So suggest you get an error log off the ECU …

I had this with my car and never did find the problem I tried everything, wheel speed sensor, plugs, leads, coil etc etc.

It’s not too funny when you are half way through overtaking a lorry and you loose all your power .

Me too… Hence the Emerald in the end

Changing the wheel speed sensor on the OSR of the car cured it once or twice but then it just started again and again…

Just out of curiosity, has everyone who has suffered this had their car outside fro long periods of time?

Just a further thought - it could be a chaffed wire from the ECU to the engine, as it passes through the bulkhead behind the passenger seat.

Just seen your message - I’m having exactly the same problem with my new Exige - it is intermittent with no power loss prior to hitting what feels like a rev limiter at 5,500rpm. Let me know if you get an answer - I’m off to the Nordschliefe next weekend…!

IMHO nobody knows what really causes this and it probably differs from car to car.

An Emerald should do the trick though.

I also had this problem ECU sreened cable broken intermitant, when cable was stretched made connection and worked fine. Problem fixed by lotus.
Even had same problem last night but this was the small allen key screw between throttle bodies. Its gone!! this made the car pop and bang and things were reduced to 5,500rpm, turned larger throttle screw in a bit got rid of pops & bangs now no shut down.

Andy, that sounds like the TB’s were imbalanced (that’s what the little screw does ) and so caused a genuine misfire…

So the software worked properly in your case…

But as randy says it many cases it’s just a mystery

Sent Message to Lotus - this was their reply:

This model was subject to a recall campaign in 2002 to reprogramme the
engine control module, and provide a safety system in case of engine
misfire. This strategy will detect a continous misfire, shut down the
corresponding pair of fuel injectors, and limit engine speed to 5,500 rpm.
This prevents unburnt fuel entering the catalytic converter and causing it
to overheat with the potential fire risk.
I recommend you contact your dealer and allow them to diagnose the cause of
the misfire, which could be related to the spark plugs or plug lead
connections to the coil.
Note that if you switch off the ignition for 10 seconds, the rev. limit will
be removed until the misfire is again detected.

gary craske from lotus and john from bell and colvill are aware of the screened cable problem. All the sensors were changed first to no avail. the cable goes from ecu to Lamba sensor point in rear bulkhead. ( Give it a wiggle ) and see if it makes a contact. New one may be needed