Battery telltale light at high RPM

Topics relating to the series 1 Exige
User avatar
deggles
Posts: 118
Joined: Tue Feb 26, 2008 12:22 pm
Location: Leeds
Been thanked: 1 time

Battery telltale light at high RPM

Post by deggles » Wed Oct 02, 2019 1:36 pm

I've noticed when giving it the beans (above about 6500rpm) my battery light flickers on. I can see via the ECU that the voltage dips to around 12.3V at this point. Most of the time voltage is around 13.9 (slightly higher at the battery terminals).

Data logger showing the point where the light comes on:
battery voltage dip.jpg
battery voltage dip.jpg (55.11 KiB) Viewed 8824 times
Any thoughts on what would cause this? Is it just a slipping alternator belt? There's no audible slippage but I guess it's quite hard to tell with the VHPD at full chat!

Am hoping the alternator isn't goosed as this one's only done a few hundred miles and not really been abused much yet. I'd have thought a failing regulator would over- rather than under-charge at higher rpm?

Any advice appreciated :thumbup:

User avatar
jonnyfox
Posts: 9114
Joined: Fri Oct 05, 2007 10:00 am
Location: Brum
Has thanked: 4 times
Been thanked: 14 times

Re: Battery telltale light at high RPM

Post by jonnyfox » Wed Oct 02, 2019 6:07 pm

I had something similar on my S2, it would flash on for a split second so hard to catch. This isn't any help at all but the Odyssey wouldn't take a charge after a while and a few months later I needed a new alternator. I'm not even sure they were related but both happened in quick time.
R300

User avatar
deggles
Posts: 118
Joined: Tue Feb 26, 2008 12:22 pm
Location: Leeds
Been thanked: 1 time

Re: Battery telltale light at high RPM

Post by deggles » Wed Oct 02, 2019 7:00 pm

Cheers, yeah, it can be chicken and egg with batteries and alternators, a bad one of either can kill the other.

Going to get the car in the air and check the belt tension tomorrow. I'm really hoping the alt doesn't have to come out as it's a right pain with the aircon pipes in the way :roll:

User avatar
andybond
Posts: 456
Joined: Thu Aug 30, 2018 9:16 am
Has thanked: 29 times
Been thanked: 16 times
Contact:

Re: Battery telltale light at high RPM

Post by andybond » Wed Oct 02, 2019 7:50 pm

Double check your terminals are tight. Mine ( s2 ) did this when I was a plonker and did not nip them up

User avatar
Rob999
Posts: 566
Joined: Sat Feb 15, 2014 6:50 pm
Location: Norfolk
Been thanked: 2 times

Re: Battery telltale light at high RPM

Post by Rob999 » Wed Oct 02, 2019 10:07 pm

Check the earthing points too...👍
#195

winthattt
Posts: 856
Joined: Fri Feb 12, 2010 4:45 pm
Location: Sunny Derbyshire
Been thanked: 2 times

Re: Battery telltale light at high RPM

Post by winthattt » Thu Oct 03, 2019 10:21 am

I’d go for a bad connection as well. When the engine is not running the battery should be 12.6 volts or there abouts. Drawing current with no alternator charging will drop the voltage. Alternating charging will lift the voltage to 14volts. Looks like it’s the connection from the alternator to the battery. I had the cable (+ve) from the back of the alternator fracture. Mine bolted on to the alternator with a simple nut and o tab. The o tab fell off and I had to drill a new hole in the remainder of the o tab and reconnect it.

Worth a look.

Post Reply