Exige S2 with added supercharger

This is where we proud owners can upload information and pictures of our pride-and-joys (their Exige that is..)
User avatar
andybond
Site Admin
Posts: 1834
Joined: Thu Aug 30, 2018 9:16 am
Contact:

Little and large at the petrol station

Image
seriouslylotus
Posts: 1947
Joined: Fri May 14, 2010 10:43 am
Contact:

andybond wrote: Mon Apr 18, 2022 8:34 am Little and large at the petrol station

Image
What little fuel and a large bill?
User avatar
andybond
Site Admin
Posts: 1834
Joined: Thu Aug 30, 2018 9:16 am
Contact:

😀😀

Don’t look , just pay and run.

Noticed the cashier had a mask on and was riding a horse which I found bizarre.
User avatar
Fonzey
Posts: 1502
Joined: Tue Nov 27, 2018 12:17 am

andybond wrote: Mon Apr 18, 2022 2:27 pm 😀😀

Don’t look , just pay and run.

Noticed the cashier had a mask on and was riding a horse which I found bizarre.
Not really weird. COVID vulnerable and horses are cheaper than petrol
johnfishcurtis
Posts: 530
Joined: Tue Jun 17, 2014 9:59 pm
Location: Nottinghamshire

Those wheels are far too nice for track use, you need to sell them to me and have my Y spokes :thumbup: ;)
User avatar
andybond
Site Admin
Posts: 1834
Joined: Thu Aug 30, 2018 9:16 am
Contact:

I took the car out a few days back to a local car event ( no pics, sorry! ) but I noted that the idle was getting "stuck" at 1500rpm and then a tap on the throttle reduced it to normal. It sometimes appeared to hunt as well.

I thought it was about time I learnt a bit more about my map, so I broke out this

Image

In a hybrid of Rob Dahm ( minus hair ) and page up from the mighty car mods I set about my tweaking

Image

I saved the map pre page up/down and post. I now have it idling without hunting. Quite happy with that. If it all goes wrong Ill revert to the previous map.

Whilst I was in the boot of the car I couldnt see the illumination of the wideband controller. Curious as to why I discovered that the data cable had unclipped itself and the actual unit was lose in the boot. Now, I am at an early stage of mapping but I know thats not a good thing.

One cable reattached and the display unit velcro'd to the boot space and we are back in business

Image
Post Reply

Create an account or sign in to join the discussion

You need to be a member in order to post a reply

Create an account

Not a member? register to join our community
Members can start their own topics & subscribe to topics
It’s free and only takes a minute

Register

Sign in