Blowing Fuses

<Archived> Even supercars have their flaws..
Zasker
Posts: 115
Joined: Mon Feb 19, 2007 12:33 pm
Location: S. Wales

Blowing Fuses

Post by Zasker »

I have an Exige S whcih was 8 months old yesterday and while out for a drive (was 60 miles from home) the rev counter and speedo started to drop to zero so I dipped the clutch and coasted to the side of the road. The engine would turn over but would not start. On investigation one of the fuses (R7 in the engine compartment) had blown. I replaced it but as soon as I turned the ignition on the fuse blew again. The car is currently with a dealer who is trying to locate the fault. I suppose I shouldn't complain as in 7 years of Lotus ownership this is my first break down of any sort (as I touch wood). Has anyone else experienced this problem?

Zasker
Posts: 115
Joined: Mon Feb 19, 2007 12:33 pm
Location: S. Wales

Re: Blowing Fuses

Post by Zasker »

Well dealer has got back to me. Don't know what is wrong and Lotus have suggested changing the engine module (ECU I assume) and see if that works. If not they are to check the wiring loom. Anyway they reckon it will be Tuesday at the earliest

User avatar
thommo
Posts: 4281
Joined: Tue Jul 13, 2004 12:50 pm
Location: Lancs
Has thanked: 1 time
Been thanked: 18 times

Re: Blowing Fuses

Post by thommo »

Keep us posted. Hope you get it going.

Zasker
Posts: 115
Joined: Mon Feb 19, 2007 12:33 pm
Location: S. Wales

Re: Blowing Fuses

Post by Zasker »

Am still waiting but have been told I should get it back tomorrow! I won't hold my breath though

Locked