2004 Exige S2...

This is where we proud owners can upload information and pictures of our pride-and-joys (their Exige that is..)
User avatar
The Hornet
Posts: 210
Joined: Wed Nov 13, 2013 4:30 pm

Fonzey wrote: Tue Jan 19, 2021 5:29 pm Great news, fingers crossed we're heading forwards now :thumbup:
Yes mate - indeed - I bloody hope so !
User avatar
thommo
Posts: 4829
Joined: Tue Jul 13, 2004 12:50 pm
Location: Lancs

The Hornet wrote: Tue Jan 19, 2021 5:33 pm
Fonzey wrote: Tue Jan 19, 2021 5:29 pm Great news, fingers crossed we're heading forwards now :thumbup:
Yes mate - indeed - I bloody hope so !
:thumbup: :thumbup:
Exige S1 No: 139
User avatar
The Hornet
Posts: 210
Joined: Wed Nov 13, 2013 4:30 pm

So new engine is run in (on dyno) and car back together - a few niggles with the EMU and the aircon. - but quickly sorted. Car went on dyno for mapping - was over boosting... Seems my CAT is knackered.

I have an early 2bular manifold and sportscat, which has a Flexi section. The latest sportscat does not have this, so Jim made me up a new cat, and a 'donut' connector to give some flex. As has always been the case for me, Jim turned this around quickly.

H111 due to fit the new Cat today - but wanted to know if I was happy without the Flexi section - which as far as I know is the same for oem and larini and others (i.e. no Flexi) - I think they were concerned as I have the engine mount inserts.

Can I solicit any other owners who have aftermarket manifolds and cats and also engine mount inserts that this has not caused them any issues ?
User avatar
matt447
Posts: 142
Joined: Mon Apr 13, 2020 7:13 pm

2bular full system including non-flexi sport cat on mine, yellow bushes front and rear of engine - no problems at all... yet ;)
User avatar
Fonzey
Posts: 1226
Joined: Tue Nov 27, 2018 12:17 am

No flexi on mine either, and the OE system has no flexi either...
Post Reply