2004 Exige S2...

This is where we proud owners can upload information and pictures of our pride-and-joys (their Exige that is..)
User avatar
The Hornet
Posts: 212
Joined: Wed Nov 13, 2013 4:30 pm

pkw2704 wrote: Tue Oct 13, 2020 9:19 pm Wow,came to this late and in the process of deciding on a katana s/c kit(used) now you have me very worried.I am not after mega power 250ish would be fine ,but now I am wondering if its all worth it with the possibility of big bills that can occur.I have the emu on my n/a which may come in handy
My issue was caused by Essex autosport putting rubber washers on my knock sensor. All evidence now points to that. I can’t prove it was them, but there is no other point that this would have been done. This was to solve mapping issues that were a weakness of the kit using the lotus ecu.

With the emu, you will be fine. Does the kit come with the intercooler? I wouldn’t supercharge without it. Even better, charge cool it
pkw2704
Posts: 61
Joined: Mon Nov 06, 2017 2:43 pm

No , no intercooler it’s the standard katana kit
ade
Posts: 7441
Joined: Thu Sep 21, 2006 10:40 am
Location: Essex

pkw2704 wrote: Wed Oct 14, 2020 5:15 am No , no intercooler it’s the standard katana kit
That at least gives you a good base with all the parts, personally I don't see an issue running them with no intercooler, they just have to be mapped correctly. As previously stated the original maps were suboptimal sadly
User avatar
The Hornet
Posts: 212
Joined: Wed Nov 13, 2013 4:30 pm

So the car went back in to Hangar 111 to get the EMU fitted and to be mapped.

On an initial run before fitting the Wideband lamda and EMU, they noticed a rattling noise - 2020 continues to kick at every turn...

They think its either the exhaust sprocket, inlet controller and/or timing chain (although its less than 1500 miles since the engine was put back together with a new bottom end.) They said they followed the Toyota guidance and there was no play or issues with the timing chain then... I also did not notice a rattle on driving it...

One day I'll get a car that works......
User avatar
Fonzey
Posts: 1232
Joined: Tue Nov 27, 2018 12:17 am

Nightmare mate, did they say when the rattle noise occurs?

It's not the issue I had with VTEC disengaging is it on gearshifts or decel? Every 2zz map I've seen so far has got this 'issue', but it doesn't seem to make the rattle noise on all cars so not everyone is aware.
User avatar
The Hornet
Posts: 212
Joined: Wed Nov 13, 2013 4:30 pm

Fonzey wrote: Fri Dec 11, 2020 8:53 am Nightmare mate, did they say when the rattle noise occurs?

It's not the issue I had with VTEC disengaging is it on gearshifts or decel? Every 2zz map I've seen so far has got this 'issue', but it doesn't seem to make the rattle noise on all cars so not everyone is aware.
They said it was a rattle when engine warms at raised revs (not high or tickover) - but they haven't put the EMU on yet - this was just an initial run to see where it was....
User avatar
Fonzey
Posts: 1232
Joined: Tue Nov 27, 2018 12:17 am

The Hornet wrote: Fri Dec 11, 2020 8:57 am
Fonzey wrote: Fri Dec 11, 2020 8:53 am Nightmare mate, did they say when the rattle noise occurs?

It's not the issue I had with VTEC disengaging is it on gearshifts or decel? Every 2zz map I've seen so far has got this 'issue', but it doesn't seem to make the rattle noise on all cars so not everyone is aware.
They said it was a rattle when engine warms at raised revs (not high or tickover) - but they haven't put the EMU on yet - this was just an initial run to see where it was....
Ah OK, not that then. Hopefully it's nothing mate - so many possible sources of a rattle in the engine bay before you even get to thinking about engine internals.
User avatar
The Hornet
Posts: 212
Joined: Wed Nov 13, 2013 4:30 pm

Fonzey wrote: Fri Dec 11, 2020 9:01 am
The Hornet wrote: Fri Dec 11, 2020 8:57 am
Fonzey wrote: Fri Dec 11, 2020 8:53 am Nightmare mate, did they say when the rattle noise occurs?

It's not the issue I had with VTEC disengaging is it on gearshifts or decel? Every 2zz map I've seen so far has got this 'issue', but it doesn't seem to make the rattle noise on all cars so not everyone is aware.
They said it was a rattle when engine warms at raised revs (not high or tickover) - but they haven't put the EMU on yet - this was just an initial run to see where it was....
Ah OK, not that then. Hopefully it's nothing mate - so many possible sources of a rattle in the engine bay before you even get to thinking about engine internals.
They think its either the exhaust sprocket, inlet controller and/or timing chain... so we will see - but I am really fed up that I spent all that money on a new bottom end, and less than 1500 miles later, there is another issue....
User avatar
Fonzey
Posts: 1232
Joined: Tue Nov 27, 2018 12:17 am

I'm not surprised.

@andybond do you still have the suspected VVT sprocket rattle on yours?
User avatar
andybond
Site Admin
Posts: 1587
Joined: Thu Aug 30, 2018 9:16 am
Contact:

Fonzey wrote: Fri Dec 11, 2020 9:17 am I'm not surprised.

@andybond do you still have the suspected VVT sprocket rattle on yours?
Not convinced mine is a VVT sprocket rattle. It only occurs for a second on initial start but if I stop and restart the engine that day it doesnt happen again ..
Post Reply