Won't fire! - HELP!

Mr Turner rang me this evening to say he thinks Costco do them for �20! I’ll take a look.

Anybody know the shelf life of a battery? Even if this one is fine, 20 quid seems like money well spent to have one sat in the shed ready just in case.

Ian

20 quid seems like money well spent to have one sat in the shed ready just in case.

Ian

No, sha’nt, won’t, to easy…

Ian

If you buy one to keep on th eshelf you need to keep it topped up (ie charged - i don’t mean with water )

Earlier you mentioned running charger leads across the ground to keep your battery conditioned… if people/bairns etc are at risk of tripping over them then I wouldn’t do this you might wish you hadn’t if it ends up damaging something or hurting someone… you defo don’t want inadvertant shorting of the battery…

Don’t worry Rox, it’s just the extension lead, not the charger itself.

For some strange reason, nobody is going in the garden at the moment! I’ll try and find a non-trailing solution (or just drive the car a lot more to reduce the need for a charger!) before Spring arrives.

Ian

ps. When does Spring start?

If you’ve read my South Wales day report - here - then you’ll probably gather that it wasn’t a battery problem.

When it happened again (after several days of charging and a 120 mile motorway run) the AA guy couldn’t get it going from a jump. He had a lead from his van AND another battery on it, we had 14V and even 12V when turning the engine over! It clearly wasn’t a voltage problem. He checked the injectors (fine) and spark (also fine). He even attached his computer and the ECU told him all was fine and dandy (the fibbing pile of poo!). It did appear to be and electrical problem though.

Eventually AndyD and Steve Edwards were able to have a look at it and scanned the workshop manual (that they just happened to have with them!) and crawled over it for 10 minutes, identifying other possible causes as the inertia switch (on the chassis rail under the airbox ducting, which turned out to be fine) but perhaps more importantly ([color:“blue”]and listen up, because this is the fix[/color]) the OTHER set of fuses (and a few relays) in the hatch behind the seat. These are for the multi-thingy immobiliser that doesn’t just cut the ignition it separately stops the fuelling, along with other stuff (it’s late, perhaps the details can be filled in by the experts). The fuse for the fuelling had corroded. So, even though the immobiliser seemed to be switched off, it wasn’t fully and stopped the ignition from switching.

So, if you get the same symptoms, open the hatch behind the drivers seat and thoroughly check those fuses!

For now, my battery lives to fight another day, and I will remain very grateful to my highly knowledgeable, long suffering and splendidly humble fellow owners.

Ian

So, if you get the same symptoms, open the hatch behind the drivers seat and thoroughly check those fuses!

Doh, those were the fuses I told you to check when we spoke on the phone!!! Well that’s what I meant by “the fuses/relays in the ECU compartment”, cos I had one of the 7.5amp fuses blow about 6 months ago. My sincere apologies for not describing their location more clearly, which would have saved you 4 hours of hanging around. Anyway, glad it worked out okay - Andy & Steve are a couple of stars

No apologies needed. We did give them a quick check but as it was after an hour of poking about I don’t think we were being as thorough as we could and Andy and Steve brought fresh hands/minds to the problem.

I ended up having a good day so all’s well that end’s well.

Ian

Okay, here’s the latest.

Got it to Lakeside and thankfully (sort of) it didn’t start so they could do some checks. I left them scratching their heads:

  • Pump works, 3 bar of pressure
  • Spark on all plugs
  • Compression okay
  • Plugs dry (ie. either no fuel, or it’s being burned…which surely it can’t be or it would at least try and fire, dry plugs may also suggest it’s not the coil)
  • The injectors were firing when the AA man checked’em last time it had this problem

They wondered about the ECU.

Any more thoughts?

Anybody got a spare 190 ECU in case I need a new one?

Ian

If it sparks on all 4 plugs then the coil is fine… It would still fire even with a faulty coil but prob on 2 cylinders.

And if the fuel pressure is good and the plugs are remaining dry then it’s the injectors that are not firing, or the plugs would get wet… very wet indeed… QED

Sounds like an immobiliser thingy to me.

Or could be the crank sensor, I was reading up on this and it takes 4 revolutions to pick up the crank timing mark so the engine will turn 4 times before firing… Unless the ECU is getting no signal from it then it would turn and turn and turn and turn ad hoc ad infinitum

If it was the ECU it probably wouldn’t spark either? Maybe?

Ian

That fuse stops the fuel pump so if its pumping it unlikely to be that.

The ECU does trigger the injectors so … but what about

Throttle pot
Crank sensor - maybe the connection is bad

Wouldn’t it still fire without the TPS? Just run like a bag of [email protected]

Oh hang on the VHPD does anyway LOL!

I think the the crank sensor is visable just below airbox in. I gave that a wiggle and it didn’t help. Lakeside said they they didn’t think it was that (for some reason I forget but made sense).

If it was the throttle pot why would it only happen at start?

Ian

Dunno Ian

Just clutching at straws I guess …

The fuel pump relay has two seperate outputs from one input - one goes to the fuel pump and one goes to the injectors - maybe worth just double checking that there is voltage output on both lines ?? Equally if an LED tester has been put on the injector connection and it lights - thats not it

Thanks Andy, I’ll mention it.

Ian &

I think Andy has hit the nail on the head there, i doubt if all 4 injector circuits have gone down on the ECU, if all your plugs were dry, none of them were opening, so the only common component would be that relay.

I think Andy has hit the nail on the head

And you’re not a man to say that kinda thing lightly. I’ll definately tell’em.

Thanks agina, Ian

Another thought chaps. Sensors.

My Caterham driving director had a similar problem on his K-series powered R500, which turned out to be a hot water sensor confusing the ECU in its start-up rountine.

Anybody know what sensors the ECU checks at start-up?

Ian

Looks like it’s fixed!

It appears to be the throttle body sensor. When hot it was reading wide open. On start-up there is a spark-plug cleaning mode (or something), that means if you start the car with the throttle wide open it doesn’t inject, that’s what was happening.

Apparently Lotus were a bit stumped on the whole thing; good old Lakeside!

Upshot, about 4 hours labour (they tried replacing the ECU first) and the sensor, should be about �250.

Ian

Great news Ian…

Congrats to Lakeside…

Of course if you had an Emerald you could have seen that happening